IDM ile İndirmeleri Başlatma
Internet Download Manager ile indirmelerinizi başlatmak için birkaç yol vardır.
1) IDM Internet Explorer, MSN Explorer, AOL, Opera, Mozilla, Netscape, ve diğer tarayıcılardaki tıklamaları izler.
Bu yöntem en kolayıdır. Internet Explorer veya başka bir tarayıcıda bir indirme bağlantısı üzerine tıklarsanız IDM indirmeyi devralacaktır ve hızlandıracaktır. Bu durumda özel bir şey yapmanıza gerek yoktur, sadece her zamanki gibi Internet'te dolaşın. IDM bir indirmeyi indirmenin türü türler/uzantılar listesi ile eşleşiyorsa Internet Explorer'dan devralır. IDM ile indirilecek türler/uzantılar listesi Seçenekler->Genel bölümünde düzenlenebilir. IDM bir indirme devraldıysa, aşağıdaki iletişim kutusunu gösterir
IE'de indirme yakalama
Daha Sonra İndir düğmesi üzerine tıklarsanız, URL (web adresi) indirmeler listesine eklenecektir, fakat indirme işlemi başlamayacaktır. İndirmeyi Başlat düğmesi üzerine tıklarsanız, IDM dosyayı indirmeye hemen başlayacaktır. IDM indirmelerinizi IDM kategorileri ile ilişkilendirmenizi sağlar. IDM dosya türüne göre kategori ve varsayılan indirme dizinini önerir. Ana IDM penceresinde kategorileri düzenleyebilir, silebilir ve yeni kategoriler ekleyebilirsiniz. İndirmeden önce bir zip dosyasının içeriğini görmek isterseniz, Önizleme düğmesi üzerine tıklayabilirsiniz.

IDM herhangi bir indirmeyi Internet Explorer'da indirme bağlantısına tıklarken CTRL tuşuna basılı tutarsanız devralacaktır. ("IDM Seçenekler->Genel" bölümündeki "CTRL tuşunu IE tıklama izleme ile kullan" kutusunu işaretlemelisiniz).

IE'de bir indirme bağlantısı üzerine tıklarken ALT tuşuna basılı tutarsanız, IDM indirmeyi devralmıyacaktır ve Internet Explorer'ın dosyayı indirmesine izin verecektir. ("IDM Seçenekler->Genel" bölümündeki "ALT tuşunu IE tıklama izleme ile kullan" kutusunu işaretlemelisiniz)

IDM'nin bir tarayıcıdan herhangi bir indirmeyi devralmasını istemiyorsanız, IDM seçeneklerinde tarayıcı ilişkilendirmesini kapatın. "IDM Seçenekler->Genel" bölümünde bir tarayıcı ilişkilendirmesini açtıktan veya kapattıktan sonra, tarayıcıyı yeniden başlatmayı unutmayın.

Internet Download Manager ile dosya indirmede sorun yaşıyorsanız, tarayıcının indirmeyi işlemesine izin vermek için bir bağlantı üzerine tıklarken Alt tuşuna basmalısınız.

2) IDM geçerli URL'ler (web adresleri) için panoyu izler.
IDM özel uzantı türleri ile URL'leri izler. Panoya bir web adresi kopyalandığında, IDM indirmeyi başlatmak için iletişim kutusunu gösterir.
Panodaki bağlantıyı yakalama
Tamam düğmesi üzerine tıklarsanız, IDM indirmeyi başlatacaktır.
3) IDM IE tabanlı (MSN, AOL, Avant) ve Mozilla tabanlı (Firefox, Netscape) tarayıcıların sağ tık menüleri ile ilişkilendirilir
Bir tarayıcıda bir bağlantı üzerine sağ tıklarsanız, "IDM ile indir" menü öğesini göreceksiniz. Bir html sayfasında seçili metindeki belirli bir bağlantıyı veya tüm bağlantıları indirebilirsiniz.
IDM indirmeyi otomatik olarak devralmıyorsa bu şekilde dosyaları indirmek kullanışlıdır. Bağlantıyı IDM ile indirmeye başlamak için sadece bu öğeyi seçin. Ayrıca Internet Explorer'da bir metini seçebilir, ve seçili metindeki tüm bağlantıları IDM'ye eklemek için "IDM ile indir" menü öğesini seçebilirsiniz.
4) URL Ekle düğmesi ile elle URL (web adresi) ekleyebilirsiniz.
Daha fazla ayrıntı için Ana İletişim Kutusu konusuna bakın
5) Bağlantıları Internet Explorer'dan ana IDM penceresine veya indirme sepetine sürükleyip bırakın
İndirme sepeti Internet Explorer, Netscape, Mozilla, AOL veya Opera tarayıcılarından sürüklenen bağlantıları kabul eden bir penceredir. İndirmelerinizi IDM ile başlatmak için tarayıcınızdan bir bağlantıyı sürükleyip bu pencereye bırakabilirsiniz.
Bu pencereyi gizlemek istiyorsanız, pencereyi kapatın. Daha sonra bu pencerenin tekrar görünmesini istiyorsanız ana menüden "Görevler-> İndirme sepetini göster" menü öğesini seçebilirsiniz.
6) Komut satırı parametrelerini kullanarak indirmelerinizi komut satırından başlatabilirsiniz
Aşağıdaki parametreleri kullanarak IDM'yi komut satırından başlatabilirsiniz.
idman /s
veya idman /d URL [/p yerel_yol] [/f yerel_dosya_adı] [/q] [/h] [/n] [/a]
Parametreler:
/d URL - bir dosya indirir, örn.
IDMan.exe /d "http://www.internetdownloadmanager.com/yol/Dosya Adı.zip"
/s - programlayıcıdaki kuyruğu başlatır
/p yerel_yol - dosyanın kaydedileceği yer olan yerel yolu açıklar
/f yerel_dosya_adı - dosyanın kaydedileceği ad olan yerel dosya adını açıklar
/q - IDM başarılı bir indirmeden sonra kapanır. Bu parametre sadece ilk kopya için çalışır
/h - IDM başarılı bir indirmeden sonra bağlantınızı kapatır
/n - IDM herhangi bir soru sormadığında sessiz modu açar
/a - indirme kuyruğuna /d ile belirtilen bir dosya ekler, fakat indirmeyi başlatmaz
/a, /h, /n, /q, /f yerel_dosya_adı, /p yerel_yol parametreleri sadece /d URL ile indirilecek dosyayı belirlediğinizde çalışır URL


Tarayıcılar ile İlişkilendirme
Tarayıcı İlişkilendirmesi seçeneklerini değiştirmek istiyorsanız, IDM araç çubuğundaki Seçenekler düğmesine tıklayarak IDM Seçeneklerine gitmeniz gerek.
Dosya türleri sekmesinde IDM tarafından bir tarayıcıdan devralınacak ve indirilecek dosya türlerinin listesini değiştirmek için kullanılır. IDM Internet Explorer, Opera, MSN Explorer, AOL, Netscape, Mozilla, Mozilla Firebird, Mozilla Firefox, MyIE2, Avant Browser, NetCaptor, GoSurf, Fast Browser, SlimBrowser, ve diğer popüler tarayıcılar ile varsayılan olarak ilişkilendirilir. Tarayıcınızı listede görmeseniz bile, tarayıcıda bir indirme başlattığınızda IDM tarayıcıyı ekleyebilir.
Bir tarayıcının ilişkilendirmesini kapatmak istiyorsanız, lütfen "Aşağıdaki tarayıcılardan indirmeleri yakala" listesinde ilgili kutunun işaretini kaldırın.
IDM'nin belirlenen sitelerden indirmesini önleyebilirsiniz. IDM'nin belirlenen bir siteden tüm indirmeleri devralmasını istemiyorsanız, siteyi "indirmeye otomatik olarak başlama" listesine ekleyebilirsiniz. Karakter sayısını eşleştirmek için yıldız işareti kullanabilirsiniz. Örnek olarak *.tonec.com, ftp.tonec.com, www.tonec.com, www.games.tonec.com, ve vb. ile eşleşecektir.
IDM'yi yeni bir tarayıcı, veya HTTP ve FTP indirme iletişim kurallarını kullanan herhangi bir uygulama ile ilişkilendirmeniz gerekiyorsa, lütfen Gelişmiş Tarayıcı İlişkilendirmesini kullanın ve "Yeni Uygulamaları Algıla" kutusunu işaretleyin. Ardından bu uygulamayı çalıştırdığınızda, ve IDM'nin otomatik olarak başlatılan indirmeler listesinden bir dosya türüne sahip olan bir dosyayı indirmeye çalıştığınızda, IDM indirmeyi bu uygulamadan devralacaktır ve uygulamayı tarayıcılar listesine ekleyecektir.
Tuşlar düğmesi IDM ile indirmeyi başlatacak veya durduracak klavye tuşlarını seçmenizi sağlar. Tuşlar düğmesi üzerine bastığınızda, "Özel tuşları kullanma" iletişim kutusu görünecektir. Tarayıcınız için uygun bir veya daha fazla tuş kombinasyonu seçebilirsiniz.